OSPF – podstawy (single area)

Cele:

Adresy IP routerów:

R1

Interfejs IP
FastEthernet 0/0 172.16.12.1/24
FastEthernet 1/0 172.16.13.1/24
Loopback 0 1.1.1.1/24

R2

Interfejs IP
FastEthernet 0/0 172.16.12.2/24
FastEthernet 1/0 172.16.23.2/24
Loopback 0 2.2.2.2/24

R3

Interfejs IP
FastEthernet 0/0 172.16.23.3/24
FastEthernet 1/0 172.16.13.3/24
Loopback 0 3.3.3.3/24

Schemat sieci:

ospf - podstawy

Router: 3640
IOS: c3640-jk9o3s-mz.124-16a.bin

Rozwiązanie

Router R1: skonfiguruj OSPF (Process ID = 1). Rozgłoś wszystkie podłączone sieci.

Włączymy obsługę OSPF na R1 oraz rozgłosimy podłączone podsieci. W tym ćwiczeniu wszystkie routery (oraz sieci) umieszczone są w obszarze zerowym (area 0 lub area 0.0.0.0). Obszar ten pośredniczy w wymianie tras między wszystkimi obszarami w domenie OSPF. Każdy obszar ma przypisany identyfikator (32 bitowa liczba). Możemy użyć liczb z przedziału od 0 do 65535. Popularne jest też zapisywanie identyfikatorów w takiej postaci jak adresy IPv4 (4 liczby w zakresie od 0-255, oddzielone kropkami). W przypadku kiedy utworzymy kilka obszarów (multi-area OSPF), każdy z nich musi być podłączony do obszaru 0 (lub 0.0.0.0). Rozgłaszając sieć w OSPF przy użyciu polecenia network musimy zawsze określić identyfikator obszaru.

R1(config)#router ospf 1
R1(config-router)#network 172.16.12.0 0.0.0.255 area 0
R1(config-router)#network 172.16.13.0 0.0.0.255 area 0
R1(config-router)#network 1.1.1.0 0.0.0.255 area 0    
R1(config-router)#exit

Polecenie router ospf 1 uruchamia proces OSPF na routerze (cyfra 1 to identyfikator procesu). Następnie rozgłaszamy wszystkie sieci określając siec, maskę wildcard oraz numer obszaru.


Router R2: skonfiguruj OSPF (Process ID = 1). Rozgłoś wszystkie podłączone sieci używając tylko dwóch poleceń network.

Postępujemy podobnie jak powyżej. Pamiętamy, że możemy użyć tylko 2 razy polecenia network.

R2(config)#router ospf 1
R2(config-router)#network 172.16.0.0 0.0.255.255 area 0
R2(config-router)#network 2.2.2.0 0.0.0.255 area 0
R2(config-router)#exit                                                                                                                                                           
R2(config)#                                                                                                                                                                      
*Mar  1 00:06:42.155: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on FastEthernet0/0 from LOADING to FULL, Loading Done

Praktycznie od razu zostajemy też poinformowani, że router R2 nawiązał sąsiedztwo z R1 (1.1.1.1). Podobny komunikat pojawia się też na konsoli R1:

R1#
*Mar  1 00:06:43.459: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on FastEthernet0/0 from LOADING to FULL, Loading Done

Router R3: skonfiguruj OSPF (Process ID = 1). Rozgłoś wszystkie podłączone sieci używając tylko jednego polecenia network.

R3(config)#router ospf 1
R3(config-router)#network 0.0.0.0 255.255.255.255 area 0
R3(config-router)#exit  

Poniżej informacja o nawiązaniu sąsiedztwa z R1 i R2:

R3(config)# 
*Mar  1 00:07:42.747: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on FastEthernet0/0 from LOADING to FULL, Loading Done
R3(config)#
*Mar  1 00:07:45.867: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on FastEthernet1/0 from LOADING to FULL, Loading Done 

Upewnij się, że możesz pingować interfejsy Loopback0 z wszystkich routerów.

Po konfiguracji OSPF, każdy router powinien mieć łączność z każdą siecią. Sprawdzimy najpierw tablicę routingu na R1:

R1#show ip route  | beg Gateway
Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Loopback0
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/2] via 172.16.12.2, 00:40:49, FastEthernet0/0
     3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/2] via 172.16.13.3, 00:40:49, FastEthernet1/0
     172.16.0.0/24 is subnetted, 3 subnets
O       172.16.23.0 [110/2] via 172.16.13.3, 00:40:49, FastEthernet1/0
                    [110/2] via 172.16.12.2, 00:40:49, FastEthernet0/0
C       172.16.12.0 is directly connected, FastEthernet0/0
C       172.16.13.0 is directly connected, FastEthernet1/0

Router nauczył się kilku nowych sieci przez protokół OSPF (litera O po lewej stronie). Upewnijmy się, że wszystko działa, pingując interfejsy Loopback 0 routera R2 oraz R3:

R1#ping 1.1.1.1 source loopback 0

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
Packet sent with a source address of 1.1.1.1 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R1#ping 2.2.2.2 source loopback 0      

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
Packet sent with a source address of 1.1.1.1 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/19/24 ms

W tablicy routingu interfejsy loopback pojawiają się z maską /32. Popraw konfigurację tak, aby wyświetlały się z poprawną maską podsieci.

Zobaczmy jeszcze raz tablicę routingu dla R1:

R1#show ip route ospf 
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/2] via 172.16.12.2, 01:57:16, FastEthernet0/0
     3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/2] via 172.16.13.3, 01:57:16, FastEthernet1/0
     172.16.0.0/24 is subnetted, 3 subnets
O       172.16.23.0 [110/2] via 172.16.13.3, 01:57:16, FastEthernet1/0
                    [110/2] via 172.16.12.2, 01:57:16, FastEthernet0/0

Widzimy, że sieci przypisane do interfejsu loopback 0 routerów R2 i R3 wyświetlane są z maską /32, pomimo że podczas konfiguracji użyliśmy maski /24 (255.255.255.0). OSPF dla interfejsów loopback automatycznie ustawia typ sieci jako właśnie LOOPBACK (Network Type LOOPBACK):

R1#show ip ospf interface loopback 0
Loopback0 is up, line protocol is up 
  Internet Address 1.1.1.1/24, Area 0 
  Process ID 1, Router ID 1.1.1.1, Network Type LOOPBACK, Cost: 1
  Loopback interface is treated as a stub Host

Zmieniając typ sieci na point-to-point zapewni, że zobaczymy właściwą maskę podsieci w tablicy routingu:

R1(config)#int l0
R1(config-if)#ip ospf network point-to-point 

Podejrzyjmy zmiany korzystając ponownie z polecenai show ip ospf interface loopback 0:

R1#show ip ospf interface l0
Loopback0 is up, line protocol is up 
  Internet Address 1.1.1.1/24, Area 0 
  Process ID 1, Router ID 1.1.1.1, Network Type POINT_TO_POINT, Cost: 1
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
  Supports Link-local Signaling (LLS)
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0 
  Suppress hello for 0 neighbor(s)

Sprawdźmy teraz tablicę routingu na R3:

R3#show ip route ospf 
     1.0.0.0/24 is subnetted, 1 subnets
O       1.1.1.0 [110/2] via 172.16.13.1, 00:02:19, FastEthernet1/0
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/2] via 172.16.23.2, 00:02:19, FastEthernet0/0
     172.16.0.0/24 is subnetted, 3 subnets
O       172.16.12.0 [110/2] via 172.16.23.2, 00:02:19, FastEthernet0/0
                    [110/2] via 172.16.13.1, 00:02:19, FastEthernet1/0

Widzimy, że sieć 1.0.0.0/24 wyświetla się teraz z poprawną maską podsieci. Oczywiście zmian musimy dokonać też na routerach R2 i R3:

R2(config)#int l0
R2(1config-if)#ip ospf network point-to-point
R3(config)#int l0
R3(config-if)#ip ospf network point-to-point

Tablica routingu na routerze R2:

R2#show ip route ospf 
     1.0.0.0/24 is subnetted, 1 subnets
O       1.1.1.0 [110/2] via 172.16.12.1, 00:12:05, FastEthernet0/0
     3.0.0.0/24 is subnetted, 1 subnets
O       3.3.3.0 [110/2] via 172.16.23.3, 00:12:05, FastEthernet1/0
     172.16.0.0/24 is subnetted, 3 subnets
O       172.16.13.0 [110/2] via 172.16.23.3, 00:12:05, FastEthernet1/0
                    [110/2] via 172.16.12.1, 00:12:05, FastEthernet0/0

Wyświetl wartości liczników: Hello, Dead, Wait, Retransmit na interfejsie FastEthernet 1/0 routera R3. Następnie zwiększ te wartości dwukrotnie na wszystkich routerach.

W sieciach typu broadcast domyślny interwał dla licznika Hello wynosi 10 sekund, a dla Dead 40 sekund. Dla sieci non-broadcast (Frame Relay) wartości te to odpowiednio 30 i 120 sekund. Polecenie show ip ospf interfaces nazwa_interfejsu wypisze nam poszczególne wartości:

FastEthernet0/0 is up, line protocol is up 
  Internet Address 172.16.12.1/24, Area 0 
  Process ID 1, Router ID 1.1.1.1, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State DR, Priority 1 
  Designated Router (ID) 1.1.1.1, Interface address 172.16.12.1
  Backup Designated router (ID) 2.2.2.2, Interface address 172.16.12.2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
...

Naszym zadaniem jest dwukrotne zwiększenie tych wartości. Zmian musimy dokonać w trybie konfiguracji interfejsu:

R1(config)#int f0/0
R1(config-if)#ip ospf hello-interval 20
R1(config-if)#ip ospf dead-interval 80
R1(config-if)#ip ospf retransmit-interval 10

Polecenie ip ospf dead-interval ma wpływ na interwał liczników dead oraz wait.

R1#show ip ospf interface fastEthernet 0/0
FastEthernet0/0 is up, line protocol is up 
  Internet Address 172.16.12.1/24, Area 0 
  Process ID 1, Router ID 1.1.1.1, Network Type BROADCAST, Cost: 1
  Transmit Delay is 10 sec, State DR, Priority 1 
  Designated Router (ID) 1.1.1.1, Interface address 172.16.12.1
  No backup designated router on this network
  Timer intervals configured, Hello 20, Dead 80, Wait 80, Retransmit 10

Co ważniejsze wartości liczników hello oraz dead muszą być takie same na pozostałych routerach. W przeciwnym razie stracimy relacje sąsiedztwa z innymi routerami.

R1#show ip ospf neighbor 
Neighbor ID     Pri   State           Dead Time   Address         Interface
3.3.3.3           1   FULL/BDR        00:00:37    172.16.13.3     FastEthernet1/0
2.2.2.2           1   FULL/DR         00:00:02    172.16.12.2     FastEthernet0/0
R1#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
3.3.3.3           1   FULL/BDR        00:00:33    172.16.13.3     FastEthernet1/0
R1#
*Mar  2 03:21:10.677: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on FastEthernet0/0 from FULL to DOWN, Neighbor Down: Dead timer expired
R1#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
3.3.3.3           1   FULL/BDR        00:00:38    172.16.13.3     FastEthernet1/0

Widzimy to na przykładzie powyżej. Polecenie show ip ospf neighbor wyświetla listę sąsiadów routera R1. Ponieważ naszych zmian dokonaliśmy na interfejsie FastEthernet 0/0 interesuje nas sąsiad o identyfikatorze 2.2.2.2 (czyli R2). Kiedy Dead Time spadnie do 0 zostajemy poinformowani o utracie relacji sąsiedztwa. Poprawmy teraz konfigurację na routerze R2:

R2#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
3.3.3.3           1   FULL/BDR        00:00:35    172.16.23.3     FastEthernet1/0
R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#int f0/0
R2(config-if)#ip ospf hello-interval 20
R2(config-if)#ip ospf dead-interval 80
R2(config-if)#ip ospf retransmit-interval 10

*Mar  2 03:26:45.901: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on FastEthernet0/0 from LOADING to FULL, Loading Done
R2#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
3.3.3.3           1   FULL/BDR        00:00:39    172.16.23.3     FastEthernet1/0
1.1.1.1           1   FULL/BDR        00:01:19    172.16.12.1     FastEthernet0/0

Znów mamy relację sąsiedztwa między R1 i R2. Widzimy też, że Dead Time jest ustawiony na 80 sekund. Ponieważ naszym zadaniem jest zmiana tych wartości na wszystkich routerach, więc wpisujemy:

R1(config)#int f1/0
R1(config-if)#ip ospf hello-interval 20
R1(config-if)#ip ospf dead-interval 80
R1(config-if)#ip ospf retransmit-interval 10
R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#int f1/0
R2(config-if)#ip ospf hello-interval 20
R2(config-if)#ip ospf dead-interval 80
R2(config-if)#ip ospf retransmit-interval 10
R3(config)#int f0/0
R3(config-if)#ip ospf hello-interval 20
R3(config-if)#ip ospf dead-interval 80
R3(config-if)#ip ospf retransmit-interval 10
R3(config-if)#int f1/0
R3(config-if)#ip ospf hello-interval 20
R3(config-if)#ip ospf dead-interval 80
R3(config-if)#ip ospf retransmit-interval 1

Sprawdźmy jeszcze czy wszystko działa na R1, R2 i R3:

R1#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
3.3.3.3           1   FULL/DR         00:01:13    172.16.13.3     FastEthernet1/0
2.2.2.2           1   FULL/DR         00:01:13    172.16.12.2     FastEthernet0/0
R2#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
3.3.3.3           1   FULL/DR         00:01:17    172.16.23.3     FastEthernet1/0
1.1.1.1           1   FULL/BDR        00:01:19    172.16.12.1     FastEthernet0/0
R3#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           1   FULL/BDR        00:01:14    172.16.13.1     FastEthernet1/0
2.2.2.2           1   FULL/BDR        00:01:14    172.16.23.2     FastEthernet0/0

Router R3: ustaw wartość router-id na 33.33.33.33. Upewnij się, że inne routery wiedzą o zmianie

Uruchamiając proces OSPF, IOS ustawia wartość router-id taką samą, jak największy aktywny adres IP routera. W przypadku routera R1 na którym skonfigurowaliśmy 2 adresy IP 172.16.12.1 oraz 172.16.13.1, router-id byłby równy 172.16.13.1. Dodatkowo, żeby móc uruchomić proces OSPF, na routerze musi być aktywny przynajmniej jeden interfejs. Jeżeli wyłączymy aktywne interfejsy, process OSPF automatycznie zostanie zakończony. Dlatego dobrym pomysłem jest użycie logicznych interfejsów, takich jak loopback, które mogą być aktywne cały czas. OSPF użyje adresu IP z interfejsu loopback jako wartości router-id (nawet jeżeli jest on niższy niż ten na fizycznych interfejsach). Jeśli mamy aktywnych więcej interfejsów pętli zwrotnej, wtedy zasada jest taka sama jak przy fizycznych interfejsach: OSPF użyje najwyższego adresu IP.
Zgodnie z powyższą zasadą router R1 powinien mieć identyfikator 1.1.1.1, R2 2.2.2.2, a R3 3.3.3.3. Sprawdźmy to:

R1#show ip ospf 
 Routing Process "ospf 1" with ID 1.1.1.1
R2#show ip ospf 
 Routing Process "ospf 1" with ID 2.2.2.2
R3#show ip ospf 
 Routing Process "ospf 1" with ID 3.3.3.3

Odpowiedź mamy już w pierwszej linii polecenia show ip ospf. Zgodnie z treścią zadania zmienimy teraz tę wartość na routerze R3:

R3(config)#router ospf 1
R3(config-router)#router-id 33.33.33.33
Reload or use "clear ip ospf process" command, for this to take effect

IOS od poinformował nas, że musimy zrestartować proces OSPF, żeby zmiany przyniosły efekt:

R3#show ip ospf  | include  ID
 Routing Process "ospf 1" with ID 3.3.3.3
R3#clear ip ospf process 
Reset ALL OSPF processes? [no]: yes
R3#show ip ospf  | include  ID
*Mar  1 01:35:09.063: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on FastEthernet1/0 from FULL to DOWN, Neighbor Down: Interface down or detached
*Mar  1 01:35:09.067: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on FastEthernet0/0 from FULL to DOWN, Neighbor Down: Interface down or detached
*Mar  1 01:35:09.207: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on FastEthernet1/0 from LOADING to FULL, Loading Done
*Mar  1 01:35:09.207: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on FastEthernet0/0 from LOADING to FULL, Loading Done

R3#show ip ospf  | include  ID
 Routing Process "ospf 1" with ID 33.33.33.33

Ostatnim krokiem jest sprawdzenie, czy nasi sąsiedzi wiedzą o tej zmianie. Użyjemy polecenia show ip ospf neighbor na R1 i R2:

R1#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
33.33.33.33       1   FULL/BDR        00:00:34    172.16.13.3     FastEthernet1/0
2.2.2.2           1   FULL/DR         00:00:32    172.16.12.2     FastEthernet0/0
R2#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
33.33.33.33       1   FULL/BDR        00:00:38    172.16.23.3     FastEthernet1/0
1.1.1.1           1   FULL/BDR        00:00:35    172.16.12.1     FastEthernet0/0

Ruch pomiędzy R1 a R3 musi przechodzić przez router R2. Do zmiany użyj polecenia cost.

Ruch sieciowy pomiędzy routerami R1 a R3 kierowany jest przez interfejs FastEthernet 1/0. Jest to dosyć oczywiste, tym bardziej że routery są ze sobą bezpośrednio połączone. OSPF używa metryki kosztu w celu określenia najlepszej trasy. Koszt jest bezpośrednio związany z interfejsami routera. Koszt danej ścieżki obliczamy ze wzoru 10^8 / przepustowość w bps. Im niższy wynik, tym większe szanse że dany interfejs zostanie wybrany do przesyłania ruchu do wybranej sieci. IOS automatycznie ustala koszt bazując na przepustowości interfejsu:

Typ interfejsu i przepustowość Koszt
Szeregowy, 56 kbps 1785
T1, 1.544 Mbps 64
10 Mbps, Ethernet 10
100 Mbps, Fast Ethernet 1
1 Gbps, Gigabit Ethernet 1

Dla interfejsów o przepustowości większej niż 100 Mbps koszt równa się zawsze 1. Dlatego musimy o tym pamiętać, jeśli nasz router ma np. zarówno interfejsy Fast Ethernet jak i Gigabit Ethernet. Inaczej będą one traktowane jako równe. Aktualne wartości cost możemy wyświetlić korzystając z polecenia show ip ospf interface brief:

R1#show ip ospf interface brief 
Interface    PID   Area            IP Address/Mask    Cost  State Nbrs F/C
Fa1/0        1     0               172.16.13.1/24     1     BDR   1/1
Fa0/0        1     0               172.16.12.1/24     1     BDR   1/1
Lo0          1     0               1.1.1.1/24         1     LOOP  0/0

Zmiany wykonujemy w trybie konfiguracji interfejsu:

R1(config)#interface fastEthernet 1/0
R1(config-if)#ip ospf cost 10
R1(config-if)#^Z
R1#show ip ospf interface brief 
Interface    PID   Area            IP Address/Mask    Cost  State Nbrs F/C
Fa1/0        1     0               172.16.13.1/24     10    BDR   1/1
Fa0/0        1     0               172.16.12.1/24     1     BDR   1/1
Lo0          1     0               1.1.1.1/24         1     LOOP  0/0

Ustawiliśmy wartość na 10, czyli tak jakby był to interfejs 10 Mbitowy. Wyświetlając teraz tablicę routingu na R1 widzimy, że ruch do sieci 3.3.3.3 jest kierowany przez router R2:

R1#show ip route  ospf 
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/2] via 172.16.12.2, 00:01:46, FastEthernet0/0
     3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/3] via 172.16.12.2, 00:01:46, FastEthernet0/0
     172.16.0.0/24 is subnetted, 3 subnets
O       172.16.23.0 [110/2] via 172.16.12.2, 00:01:46, FastEthernet0/0

Polecenie traceroute 3.3.3.3

R1#traceroute 3.3.3.3

Type escape sequence to abort.
Tracing the route to 3.3.3.3

  1 172.16.12.2 32 msec 28 msec 20 msec
  2 172.16.23.3 28 msec *  36 msec

Ruch pomiędzy R2 a R1 musi przechodzić przez router R3. Do zmiany użyj polecenia bandwidth.

Sytuacja podobna jak w poprzednim zadaniu. Tym razem musimy jednak zmienić przepustowość interfejsu. Zmniejszymy przepustowość interfejsu FastEthernet 0/0 routera R2 do wartości 1000 Kbps:

R2(config)#interface fastEthernet 0/0
R2(config-if)#bandwidth 1000
R2(config-if)#^Z
R2#show interfaces fastEthernet 0/0
FastEthernet0/0 is up, line protocol is up 
  Hardware is AmdFE, address is cc01.7e9a.0000 (bia cc01.7e9a.0000)
  Internet address is 172.16.12.2/24
  MTU 1500 bytes, BW 1000 Kbit, DLY 100 usec

Zmiany dokonujemy oczywiście w trybie konfiguracji interfejsu, a następnie upewniamy się tylko korzystając z polecenia show interfaces fastEthernet 0/0 (BW 1000 Kbit). Korzystając z polecenia show ip ospf interface brief widzimy, że koszt zwiększył się do 100 (zgodnie ze wzorem):

R2#show ip ospf interface brief 
Interface    PID   Area            IP Address/Mask    Cost  State Nbrs F/C
Fa1/0        1     0               172.16.23.2/24     1     BDR   1/1
Fa0/0        1     0               172.16.12.2/24     100   DR    1/1

Czas na tablicę routingu R2:

R2#show ip route ospf 
     1.0.0.0/32 is subnetted, 1 subnets
O       1.1.1.1 [110/3] via 172.16.23.3, 00:03:47, FastEthernet1/0
     3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/2] via 172.16.23.3, 00:03:47, FastEthernet1/0
     172.16.0.0/24 is subnetted, 3 subnets
O       172.16.13.0 [110/2] via 172.16.23.3, 00:03:47, FastEthernet1/0

I jak widzimy ruch do sieci 1.1.1.1 przesyłany jest przez router R3, a nie jak poprzednio bezpośrednio do R1.

R2#traceroute 1.1.1.1

Type escape sequence to abort.
Tracing the route to 1.1.1.1

  1 172.16.23.3 12 msec 16 msec 16 msec
  2 172.16.13.1 32 msec *  16 msec

Zostaw komentarz


Podpowiedź - możesz użyć tych HTML tagów i atrybutów:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

Obraz CAPTCHY

*